Quick Note: Limit interface total bandwidth by Queue Tree

22
5908

1

Requirement:

Limit interface total bandwidth , Lets say we want to limit ether1 interface (wan or whatever) to total 1 mb for upload / download.

Use following.

1
2
3
4
5
6
7
8
9
/ip firewall mangle
add action=mark-packet chain=prerouting comment="Mark Packets for Upload on WAN interface / jz" in-interface=ether1 new-packet-mark=upload
add action=mark-packet chain=postrouting comment="Mark Packets for Download on WAN interface / jz" new-packet-mark=download out-interface=ether1
/queue tree
add comment="Limit Total Traffic to 1mb in Queue Tree / Jz" disabled=yes max-limit=1M name=total-traffic parent=global queue=default
add comment="Limit upload Packets marked by mangle / Jz" disabled=yes name=upload packet-mark=upload parent=total-traffic queue=default
add comment="Limit download Packets marked by mangle / Jz" disabled=yes name=download packet-mark=download parent=total-traffic queue=default

 

You can use it to distribute specific amount of bandwidth to specific subnet or number of users. Example if you have 10 mb of bandwidth link and you want to distribute 5 mb to specific number of users. Lot of otehr queuing trick you can do.

Regard’s

22 COMMENTS

  1. Hey there I am so happy I found your weblog,
    I really found you by mistake, while I was looking
    on Digg for something else, Regardless I am here now
    and would just like to say many thanks for a tremendous post and a all round entertaining
    blog (I also love the theme/design), I don’t have time to read through it all at the minute but I have saved it and also added in your RSS feeds,
    so when I have time I will be back to read a lot more, Please do keep up the excellent jo.

  2. This is the perfect web site for everyone
    who hopes to find out about this topic. You know a whole lot its almost tough to argue with you (not that I actually would want toHaHa).
    You certainly put a fresh spin on a topic that has been written about for a
    long time. Excellent stuff, just excellent!

  3. Howdy! This post could not be written much better!
    Checking out this post reminds me of my previous roommate!

    He constantly kept discussing this. I am going to forward this informative article to him.

    Confident he will have got a good read. Thanks for sharing!

  4. I used to be pretty pleased to uncover this amazing site.
    I would like to to thank you for your time simply for this wonderful read!!

    I definitely enjoyed every tiny amount of it and i perhaps you have saved being a favorite to check out
    new information in your blog.

  5. Hi excellent blog! Does running a blog such as this require a large amount of work?
    I have absolutely no knowledge of programming but I was hoping to start my
    own blog in the near future. Anyhow, should you have any suggestions
    or tips for new blog owners please share. I understand this is off
    subject nevertheless I simply wanted to ask. Cheers!

  6. I feel this is certainly among the a lot important info to me.

    And i’m glad studying your article. However wanna
    observation on some general things, The web site style is wonderful, the
    articles is in reason for fact great : D. Excellent task,
    cheers